Page 1 of 1 [ 7 posts ] 

ChangelingGirl
Veteran
Veteran

User avatar

Joined: 18 Sep 2007
Age: 34
Gender: Female
Posts: 1,640
Location: Netherlands

17 Oct 2009, 8:07 am

Does anyone else find that Firefox opens each new tab in a new window? It used to open new tabs in the same window, but for some reason that doesn't work anymore. I looked into the manual and it told me to go to Tools > Preferences > Advanced and select something about tabs there, but there is no such field anywhere there, and nothing in Preferences > Tabs thing that will change this either. Anyone know how I can fix this?



southwestforests
Veteran
Veteran

User avatar

Joined: 18 Jul 2009
Age: 57
Gender: Male
Posts: 1,138
Location: A little ways south of the river

17 Oct 2009, 8:23 am

I'm not the computer geek in the family, but give me a minute to look.

Okay, up at left where it says File Edit View History Bookmarks Tools Help

Left click on Tools

go down to Options on menu thst comes up and click on it

Should be a box open with Main Tabs Content Applications Privacy Security Advanced across top

Click on Tabs

Right at top is where to click button to chose new window or tab when opeining things.


_________________
"Every time you don't follow your inner guidance,
you feel a loss of energy, loss of power, a sense of spiritual deadness."
- Shakti Gawain


ChangelingGirl
Veteran
Veteran

User avatar

Joined: 18 Sep 2007
Age: 34
Gender: Female
Posts: 1,640
Location: Netherlands

17 Oct 2009, 9:21 am

southwestforests wrote:
I'm not the computer geek in the family, but give me a minute to look.

Okay, up at left where it says File Edit View History Bookmarks Tools Help

Left click on Tools

go down to Options on menu thst comes up and click on it

Should be a box open with Main Tabs Content Applications Privacy Security Advanced across top

Click on Tabs

Right at top is where to click button to chose new window or tab when opeining things.


Tried that (oh well, I use Firefox in Dutch, but I guess the box that says something like "open new window in a new tab" is the one you mean). Checking the box didn't work though; new tabs still get opened in new windows.



southwestforests
Veteran
Veteran

User avatar

Joined: 18 Jul 2009
Age: 57
Gender: Male
Posts: 1,138
Location: A little ways south of the river

17 Oct 2009, 9:38 am

Aww, sorry. :?

Works on this machine, wonder what the difference is. :?:
There must be a difference between English and Dutch versions somewho then?
Or a bug that needs to be fixed?
Or something beyond my knowledge.


_________________
"Every time you don't follow your inner guidance,
you feel a loss of energy, loss of power, a sense of spiritual deadness."
- Shakti Gawain


Orwell
Veteran
Veteran

User avatar

Joined: 8 Aug 2007
Age: 31
Gender: Male
Posts: 12,518
Location: Room 101

17 Oct 2009, 11:46 am

Try installing the TabMixPlus addon, it will give you a lot more control over Firefox's tabbed browsing behavior.


_________________
WAR IS PEACE
FREEDOM IS SLAVERY
IGNORANCE IS STRENGTH


ChangelingGirl
Veteran
Veteran

User avatar

Joined: 18 Sep 2007
Age: 34
Gender: Female
Posts: 1,640
Location: Netherlands

17 Oct 2009, 3:58 pm

Orwell wrote:
Try installing the TabMixPlus addon, it will give you a lot more control over Firefox's tabbed browsing behavior.


Thanks. Did that. It now seems to do what I want when I set something to "one-window mode" in that add-on. Still don't understand why it's always worked without any add-ons and suddenly I need to get an add-on for this.



CloudWalker
Veteran
Veteran

User avatar

Joined: 26 Mar 2009
Age: 31
Gender: Male
Posts: 711

17 Oct 2009, 4:33 pm

Never heard of such issue before. Does that happen when you open firefox in safe mode and disable all add-ons?

Just a thought, type "about:config" in the address bar and check these settings:
browser.link.open_external = 3
browser.link.open_newwindow = 3
browser.link.open_newwindow.restriction = 0