How can I get custom content to show up on Sims 2??

Page 1 of 1 [ 2 posts ] 

Joe90
Veteran
Veteran

User avatar

Joined: 23 Feb 2010
Gender: Female
Posts: 16,723
Location: Maidstone, UK

20 Jan 2019, 6:04 am

I bet I won't get any replies, as the Sims 2 is not only an old game but it does not interest most Aspies the same way Minecraft or Pokemon Go does. But it's worth giving it a go.

I have a Windows 7 laptop and I have the Sims 2 plus all of the expansion packs installed, and it works perfectly. But I've been trying to download custom content for my Sims kids, because even with all the expansion packs there's still not a tremendous amount of toys for the kids.
I looked through the Mod the Sims 2 website and found a cool toy kitchen for the kids to play with (not an easy bake oven but an actual playset), and I downloaded it. I had enabled the CC in the game's settings but when I clicked onto the CC in the game after I had downloaded the mesh, there was nothing there, just a blank box. I went into the buy mode to see if it was there but it wasn't.

I downloaded the mesh into the 'Downloads' subfolder for the Sims 2, where it is supposed to go, but still no CC shows up in the game.

Does anyone here have any idea how I can get the CC to show up in the game? Am I doing something wrong? Replies would be appreciated.


_________________
Female
Aged 29
On antidepressants
Diagnosed with AS, ADHD and anxiety disorder


Blue_Star
Yellow-bellied Woodpecker
Yellow-bellied Woodpecker

User avatar

Joined: 3 Sep 2009
Age: 38
Gender: Female
Posts: 71

21 Jan 2019, 9:37 pm

I haven't played a the sims game in years, but I used to do that successfully. Perhaps you didn't unpack/decompress the files? I tended to not use mods since so many were rar archives instead of plain zip.

How to Install Sims 2 Mods

File Types
Extracting Files
Installing to the Correct Location
There are more. Just follow the links to the next article near the bottom of content.

Others ideas would be to completely remove the files and re-download, etc. Some just may not work for one reason or another. Do other mods show up in game properly?